summaryrefslogtreecommitdiffstats
path: root/configs/bash/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configs/bash/default.nix')
-rw-r--r--configs/bash/default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/configs/bash/default.nix b/configs/bash/default.nix
index 2e18d5b..46b90b1 100644
--- a/configs/bash/default.nix
+++ b/configs/bash/default.nix
@@ -1,4 +1,13 @@
{ config, mylib, pkgs, ... }: {
+ environment.etc.inputrc.source = pkgs.writeText "inputrc" /* readline */ ''
+ set bell-style visible
+ set colored-stats on
+ set editing-mode vi
+ set show-mode-in-prompt on
+ # [cursor] keep in sync with <hrm/configs/vim.nix>
+ set vi-ins-mode-string \1\e[6 q\2
+ set vi-cmd-mode-string \1\e[2 q\2
+ '';
programs.bash = {
interactiveShellInit = /* sh */ ''
HISTCONTROL='erasedups:ignorespace'