summaryrefslogtreecommitdiffstats
path: root/tv/configs/consul-server.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-07-28 15:29:59 +0200
committerlassulus <lass@aidsballs.de>2015-07-28 15:29:59 +0200
commit7acd1262519d8f15c8eb89a0dce968eb26d6b7d4 (patch)
tree71f807a36e60e126b6fdb0be51e70cde4bf64b4e /tv/configs/consul-server.nix
parent7673c84204bd5bae0426b79c62e95dfccf846756 (diff)
parent7920cfad18e69ea30bbe5e70da2cd93e0bbc05cd (diff)
Merge branch 'tv' into master
Diffstat (limited to 'tv/configs/consul-server.nix')
-rw-r--r--tv/configs/consul-server.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/tv/configs/consul-server.nix b/tv/configs/consul-server.nix
new file mode 100644
index 0000000..d10f9ea
--- /dev/null
+++ b/tv/configs/consul-server.nix
@@ -0,0 +1,21 @@
+{ config, ... }:
+
+{
+ tv.consul = rec {
+ enable = true;
+
+ self = config.krebs.build.host;
+ inherit (self) dc;
+
+ server = true;
+
+ hosts = with config.krebs.hosts; [
+ # TODO get this list automatically from each host where tv.consul.enable is true
+ cd
+ mkdir
+ nomic
+ rmdir
+ #wu
+ ];
+ };
+}