summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/vim
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2019-05-21 21:56:25 +0200
committertv <tv@krebsco.de>2019-05-21 22:03:00 +0200
commit52a58bc149146140413e5299609759a589681e8a (patch)
treef3899d9951873b11e7ef3bd607dbc33405efc7f7 /tv/5pkgs/vim
parent1add863e63ae834bf6f728d5827ccdaabcec0584 (diff)
tv vim: move vim to overlay
Diffstat (limited to 'tv/5pkgs/vim')
-rw-r--r--tv/5pkgs/vim/vim.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/tv/5pkgs/vim/vim.nix b/tv/5pkgs/vim/vim.nix
new file mode 100644
index 0000000..216ab6a
--- /dev/null
+++ b/tv/5pkgs/vim/vim.nix
@@ -0,0 +1,16 @@
+with import <stockholm/lib>;
+{ pkgs }:
+
+(rtp: rtp // { inherit rtp; }) (pkgs.writeTextFile (let
+ name = "vim";
+in {
+ name = "vim-syntax-${name}-1.0.0";
+ destination = "/syntax/${name}.vim";
+ text = /* vim */ ''
+ ${concatMapStringsSep "\n" (s: /* vim */ ''
+ syn keyword vimColor${s} ${s}
+ \ containedin=ALLBUT,vimComment,vimLineComment
+ hi vimColor${s} ctermfg=${s}
+ '') (map (i: lpad 3 "0" (toString i)) (range 0 255))}
+ '';
+}))