summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/simple
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2018-11-28 14:41:56 +0100
committertv <tv@krebsco.de>2018-11-28 14:41:56 +0100
commit9e40429f41984d8530c0ebcdb75d822da30be786 (patch)
treef77060270fd0e122239fd90eef05b43425de9e02 /tv/5pkgs/simple
parentfb42f758335d0792e1bbc9e00ce6c5b079fb1cfd (diff)
tv xmonad: add currentSystem to executable name
This prevents journal messges like: XMonad is recompiling and replacing itself another XMonad process because the current process is called "xmonad" but the compiled configuration should be called "xmonad-x86_64-linux"
Diffstat (limited to 'tv/5pkgs/simple')
-rw-r--r--tv/5pkgs/simple/xmonad-tv/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tv/5pkgs/simple/xmonad-tv/default.nix b/tv/5pkgs/simple/xmonad-tv/default.nix
index a2525e0..430e6a8 100644
--- a/tv/5pkgs/simple/xmonad-tv/default.nix
+++ b/tv/5pkgs/simple/xmonad-tv/default.nix
@@ -1,6 +1,6 @@
{ pkgs, ... }:
pkgs.writeHaskellPackage "xmonad-tv" {
- executables.xmonad = {
+ executables."xmonad-${builtins.currentSystem}" = {
extra-depends = [
"containers"
"extra"