summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/haskell/xmonad-tv
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2018-12-03 22:48:11 +0100
committertv <tv@krebsco.de>2018-12-03 22:48:11 +0100
commit740340ae840eb13012d6c08dfe0f924b58eec5e3 (patch)
tree3933451893539074953f21702a32b17f0202e982 /tv/5pkgs/haskell/xmonad-tv
parent0fe643ba5050e05991ac1c1e8a9cc7f8038ca2e1 (diff)
tv xmonad shell: prevent double yield
Diffstat (limited to 'tv/5pkgs/haskell/xmonad-tv')
-rw-r--r--tv/5pkgs/haskell/xmonad-tv/shell.nix13
1 files changed, 9 insertions, 4 deletions
diff --git a/tv/5pkgs/haskell/xmonad-tv/shell.nix b/tv/5pkgs/haskell/xmonad-tv/shell.nix
index 936e696..6ca00bc 100644
--- a/tv/5pkgs/haskell/xmonad-tv/shell.nix
+++ b/tv/5pkgs/haskell/xmonad-tv/shell.nix
@@ -46,7 +46,7 @@ in
xmonad_restart() {(
set -efu
cd "$WORKDIR"
- if systemctl is-active xmonad; then
+ if systemctl --quiet is-active xmonad; then
sudo systemctl stop xmonad
cp -b "$config_XMONAD_CACHE_DIR"/xmonad.state "$CACHEDIR"/
echo "xmonad.state: $(cat "$CACHEDIR"/xmonad.state)"
@@ -59,9 +59,14 @@ in
xmonad_yield() {(
set -efu
- "$xmonad" --shutdown
- cp -b "$CACHEDIR"/xmonad.state "$config_XMONAD_CACHE_DIR"/
- sudo systemctl start xmonad
+ if ! systemctl --quiet is-active xmonad; then
+ "$xmonad" --shutdown
+ cp -b "$CACHEDIR"/xmonad.state "$config_XMONAD_CACHE_DIR"/
+ sudo systemctl start xmonad
+ else
+ echo "xmonad.service is already running" >&2
+ exit -1
+ fi
)}
export PATH=${config.systemd.services.xmonad.path}:$PATH