summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2022-12-12 19:44:00 +0100
committermakefu <github@syntax-fehler.de>2022-12-12 19:44:00 +0100
commitaa1e058ba6e8c3e701a2503d65ddb3c83d5c4f47 (patch)
treeea3e3bbc78c78f39b2a8e123901867e1e68c21c7 /tv/5pkgs/default.nix
parent3a65e49a98fc1721cbc34859a18d324789abfeee (diff)
parentc0378866356b182206aa7ad47f1139cf37f697f4 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'tv/5pkgs/default.nix')
-rw-r--r--tv/5pkgs/default.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tv/5pkgs/default.nix b/tv/5pkgs/default.nix
index 5a018a1..245d054 100644
--- a/tv/5pkgs/default.nix
+++ b/tv/5pkgs/default.nix
@@ -1,4 +1,4 @@
-with import ../../lib;
+with import ./lib;
let
pushBack = x: xs:
if elem x xs then
@@ -14,7 +14,6 @@ fix
(foldl' (flip extends) (_: super)
(map
(name: import (./. + "/${name}"))
- (filter
- (name: name != "default.nix" && !hasPrefix "." name)
- (pushBack "override"
- (attrNames (readDir ./.))))))
+ (pushBack "override"
+ (attrNames
+ (filterAttrs isNixDirEntry (readDir ./.))))))