summaryrefslogtreecommitdiffstats
path: root/tv/4lib/modules.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-11-09 19:09:40 +0100
committertv <tv@krebsco.de>2015-11-09 19:09:40 +0100
commit5af50d4eda2ebd78d36968be3d835ffca0efd455 (patch)
treeef25cb18915738e1de84979d494961091385d018 /tv/4lib/modules.nix
parent2ae2303976bc1ba7941a7545bb0f61a58b6d38e9 (diff)
tv lib: bye & thanks for fish
Diffstat (limited to 'tv/4lib/modules.nix')
-rw-r--r--tv/4lib/modules.nix21
1 files changed, 0 insertions, 21 deletions
diff --git a/tv/4lib/modules.nix b/tv/4lib/modules.nix
deleted file mode 100644
index 248e638..0000000
--- a/tv/4lib/modules.nix
+++ /dev/null
@@ -1,21 +0,0 @@
-let
- pkgs = import <nixpkgs> {};
- inherit (pkgs.lib) concatMap hasAttr;
-in rec {
-
- no-touch-args = {
- config = throw "no-touch-args: can't touch config!";
- lib = throw "no-touch-args: can't touch lib!";
- pkgs = throw "no-touch-args: can't touch pkgs!";
- };
-
- # list-imports : path -> [path]
- # Return a module's transitive list of imports.
- # XXX duplicates won't get eliminated from the result.
- list-imports = path:
- let module = import path no-touch-args;
- imports = if hasAttr "imports" module
- then concatMap list-imports module.imports
- else [];
- in [path] ++ imports;
-}