summaryrefslogtreecommitdiffstats
path: root/tv/4lib/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-07-28 21:56:10 +0200
committermakefu <github@syntax-fehler.de>2015-07-28 21:56:10 +0200
commit41b5ec6ecd1cb2f38fc593ce545ef76188198318 (patch)
tree44f2f12060671dd0107d49a8fae2a5ac8728ccbb /tv/4lib/default.nix
parent37799f2fbc5e2751755e4094460f8dbdfa6828a8 (diff)
parent074bbdf5b5c6d70d58f923f3a91b71bbf18abc9c (diff)
Merge remote-tracking branch 'cd/user-toplevel' into user-toplevel
Diffstat (limited to 'tv/4lib/default.nix')
-rw-r--r--tv/4lib/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/tv/4lib/default.nix b/tv/4lib/default.nix
new file mode 100644
index 0000000..e0a295f
--- /dev/null
+++ b/tv/4lib/default.nix
@@ -0,0 +1,27 @@
+{ lib, pkgs, ... }:
+
+let
+ krebs = import ../../4lib/krebs { inherit lib; };
+in
+
+with krebs;
+
+krebs // rec {
+
+ git = import ./git.nix {
+ lib = krebs;
+ inherit pkgs;
+ };
+
+ # "7.4.335" -> "74"
+ majmin = with lib; x : concatStrings (take 2 (splitString "." x));
+
+ shell-escape =
+ let
+ isSafeChar = c: match "[-./0-9_a-zA-Z]" c != null;
+ in
+ stringAsChars (c:
+ if isSafeChar c then c
+ else if c == "\n" then "'\n'"
+ else "\\${c}");
+}