summaryrefslogtreecommitdiffstats
path: root/tv/3modules/hosts.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-08-02 21:51:39 +0200
committertv <tv@krebsco.de>2016-08-02 21:51:39 +0200
commitc5f868377e895bf8ced61c1137d377ac82983a03 (patch)
tree168d24535dac7984e08ca4359943cb548fbe9779 /tv/3modules/hosts.nix
parent450545461badca9da4724a2e8b8e2370bd03b534 (diff)
tv.hosts: init
Diffstat (limited to 'tv/3modules/hosts.nix')
-rw-r--r--tv/3modules/hosts.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/tv/3modules/hosts.nix b/tv/3modules/hosts.nix
new file mode 100644
index 0000000..7bf3267
--- /dev/null
+++ b/tv/3modules/hosts.nix
@@ -0,0 +1,12 @@
+{ config, ... }:
+
+with config.krebs.lib;
+
+{
+ options.tv.hosts = mkOption {
+ type = types.attrsOf types.host;
+ default =
+ filterAttrs (_: host: host.owner.name == "tv")
+ config.krebs.hosts;
+ };
+}