summaryrefslogtreecommitdiffstats
path: root/tv/2configs/urlwatch.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2023-02-02 14:28:13 +0100
committertv <tv@krebsco.de>2023-02-02 15:25:55 +0100
commite5d334ea76fc3d4c680ed900299e5c07247cd498 (patch)
tree237d5ba48e190014482ff298084c25e82a05e6fd /tv/2configs/urlwatch.nix
parent3693f8f2b860b0742c6afe3817a3185ebaf8873b (diff)
tv urlwatch: add samsung consumer-storage tools
Diffstat (limited to 'tv/2configs/urlwatch.nix')
-rw-r--r--tv/2configs/urlwatch.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tv/2configs/urlwatch.nix b/tv/2configs/urlwatch.nix
index e2cd199..f5260ee 100644
--- a/tv/2configs/urlwatch.nix
+++ b/tv/2configs/urlwatch.nix
@@ -9,6 +9,9 @@ with import ./lib;
};
json = json' ["."];
json' = exec "${pkgs.jq}/bin/jq";
+ urigrep' = exec (pkgs.writeDash "urigrep" ''
+ ${pkgs.urix}/bin/urix | ${pkgs.gnugrep}/bin/grep -E "$1"
+ '');
xml = xml' ["--format" "-"];
xml' = exec "${pkgs.libxml2}/bin/xmllint";
in {
@@ -69,6 +72,8 @@ in {
https://raw.githubusercontent.com/NixOS/nixpkgs/master/nixos/modules/services/x11/xserver.nix
https://www.rabbitmq.com/changelog.html
+
+ (urigrep' ["software-resources"] https://semiconductor.samsung.com/consumer-storage/support/tools/)
];
hooksFile = toFile "hooks.py" ''
import subprocess