summaryrefslogtreecommitdiffstats
path: root/tv/2configs/im.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-02-17 17:23:19 +0100
committertv <tv@krebsco.de>2016-02-17 17:23:19 +0100
commitb100a6222013be6ceb16cdaf6660292a69211e47 (patch)
tree6310b5bf5d62251f10118e25bc9cac72d3408556 /tv/2configs/im.nix
parent6860a92d8b4640bcb7cc6314589332bf3e940589 (diff)
tv im: init
Diffstat (limited to 'tv/2configs/im.nix')
-rw-r--r--tv/2configs/im.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/tv/2configs/im.nix b/tv/2configs/im.nix
new file mode 100644
index 0000000..db1be7f
--- /dev/null
+++ b/tv/2configs/im.nix
@@ -0,0 +1,24 @@
+{ config, lib, pkgs, ... }:
+with config.krebs.lib;
+{
+ environment.systemPackages = with pkgs; [
+ (pkgs.writeDashBin "im" ''
+ export PATH=${makeSearchPath "bin" (with pkgs; [
+ tmux
+ gnugrep
+ weechat
+ ])}
+ if tmux list-sessions -F\#S | grep -q '^im''$'; then
+ exec tmux attach -t im
+ else
+ exec tmux new -s im weechat
+ fi
+ '')
+ ];
+ services.bitlbee = {
+ enable = true;
+ plugins = [
+ pkgs.bitlbee-facebook
+ ];
+ };
+}