summaryrefslogtreecommitdiffstats
path: root/tv/2configs/hw/w110er.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2021-12-11 11:30:58 +0100
committerlassulus <lassulus@lassul.us>2021-12-11 11:30:58 +0100
commitc19b673a979d592acf6fd0f71b4ef144dd59a117 (patch)
treea9a727501c7bfc93e71563a37264208e09106b7f /tv/2configs/hw/w110er.nix
parentc741725c087caf9fc7fe89b204b0d06298ee4554 (diff)
parentfd54b74ddf6b1e9ba4f2fb544f05f5f97996d09c (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'tv/2configs/hw/w110er.nix')
-rw-r--r--tv/2configs/hw/w110er.nix26
1 files changed, 15 insertions, 11 deletions
diff --git a/tv/2configs/hw/w110er.nix b/tv/2configs/hw/w110er.nix
index 818d1ac..09dd9a4 100644
--- a/tv/2configs/hw/w110er.nix
+++ b/tv/2configs/hw/w110er.nix
@@ -1,7 +1,6 @@
-with import <stockholm/lib>;
-{ pkgs, ... }:
-
-{
+{ pkgs, ... }: let
+ lib = import <stockholm/lib>;
+in {
imports = [
../smartd.nix
{
@@ -16,6 +15,18 @@ with import <stockholm/lib>;
# "nvidia-settings"
#];
}
+
+ {
+ nix.buildCores = 4;
+ nix.maxJobs = 4;
+ }
+ (if lib.versionAtLeast (lib.versions.majorMinor lib.version) "21.11" then {
+ nix.daemonCPUSchedPolicy = "batch";
+ nix.daemonIOSchedPriority = 1;
+ } else {
+ nix.daemonIONiceLevel = 1;
+ nix.daemonNiceLevel = 1;
+ })
];
boot.extraModprobeConfig = ''
@@ -35,13 +46,6 @@ with import <stockholm/lib>;
networking.wireless.enable = true;
- nix = {
- buildCores = 4;
- maxJobs = 4;
- daemonIONiceLevel = 1;
- daemonNiceLevel = 1;
- };
-
services.logind.extraConfig = ''
HandleHibernateKey=ignore
HandleLidSwitch=ignore