summaryrefslogtreecommitdiffstats
path: root/tv/2configs/hw/w110er.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-10-29 01:09:54 +0100
committertv <tv@krebsco.de>2015-10-29 01:33:14 +0100
commit4654a7288190f814a194faf0911b428f3ad7b35a (patch)
treef450f8a40efb1ddbdaa4b47fbe3475a93e625245 /tv/2configs/hw/w110er.nix
parent5ff78acfaa34415e6eb34d3b4771679b3052b38c (diff)
tv config: split stuff into fs and hw
Diffstat (limited to 'tv/2configs/hw/w110er.nix')
-rw-r--r--tv/2configs/hw/w110er.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/tv/2configs/hw/w110er.nix b/tv/2configs/hw/w110er.nix
new file mode 100644
index 0000000..aa82924
--- /dev/null
+++ b/tv/2configs/hw/w110er.nix
@@ -0,0 +1,46 @@
+{ pkgs, ... }:
+
+{
+ imports = [
+ ../smartd.nix
+ ];
+
+ boot.extraModprobeConfig = ''
+ options kvm_intel nested=1
+ '';
+
+ boot.initrd.availableKernelModules = [ "ahci" ];
+ boot.kernelModules = [ "kvm-intel" ];
+
+ boot.loader.gummiboot.enable = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+
+ networking.wireless.enable = true;
+
+ nix = {
+ buildCores = 4;
+ maxJobs = 4;
+ daemonIONiceLevel = 1;
+ daemonNiceLevel = 1;
+ };
+
+ services.logind.extraConfig = ''
+ HandleHibernateKey=ignore
+ HandleLidSwitch=ignore
+ HandlePowerKey=ignore
+ HandleSuspendKey=ignore
+ '';
+
+ services.xserver = {
+ vaapiDrivers = [ pkgs.vaapiIntel ];
+ };
+
+ system.activationScripts.powertopTunables = ''
+ echo 1 > /sys/module/snd_hda_intel/parameters/power_save
+ echo 1500 > /proc/sys/vm/dirty_writeback_centisecs
+ (cd /sys/bus/pci/devices
+ for i in *; do
+ echo auto > $i/power/control # defaults to 'on'
+ done)
+ '';
+}