summaryrefslogtreecommitdiffstats
path: root/tv/2configs/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-10-24 14:38:54 +0200
committertv <tv@krebsco.de>2016-10-24 14:38:54 +0200
commiteabe9ae4ecebf8013f7901dd1e05f3857ebfb17c (patch)
tree4320f8cce694e3b1c29021fa51affb33954756df /tv/2configs/default.nix
parentf53bd6a23d94fd6b0198f9c69c115fad05c088cd (diff)
tv: DRY up ca-bundle defs
Diffstat (limited to 'tv/2configs/default.nix')
-rw-r--r--tv/2configs/default.nix15
1 files changed, 8 insertions, 7 deletions
diff --git a/tv/2configs/default.nix b/tv/2configs/default.nix
index 39d0c4f..0854e53 100644
--- a/tv/2configs/default.nix
+++ b/tv/2configs/default.nix
@@ -112,13 +112,14 @@ with import <stockholm/lib>;
};
}
- (let ca-bundle = "${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt"; in {
- environment.variables = {
- CURL_CA_BUNDLE = "${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt";
- GIT_SSL_CAINFO = "${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt";
- SSL_CERT_FILE = "${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt";
- };
- })
+ {
+ environment.variables =
+ flip genAttrs (_: "${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt") [
+ "CURL_CA_BUNDLE"
+ "GIT_SSL_CAINFO"
+ "SSL_CERT_FILE"
+ ];
+ }
{
services.cron.enable = false;