summaryrefslogtreecommitdiffstats
path: root/tv/2configs/consul-server.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-07-28 20:40:25 +0200
committertv <tv@krebsco.de>2015-07-28 20:40:25 +0200
commitfc9f8d985098cce3c4386810f6c487ca3884f336 (patch)
treef1033088f116f8683ebe94c4b3576f440af949f6 /tv/2configs/consul-server.nix
parenta5fe66d5e3d9b76914e48db769a31135081d8555 (diff)
tv: reintroduce directory numbers
Diffstat (limited to 'tv/2configs/consul-server.nix')
-rw-r--r--tv/2configs/consul-server.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/tv/2configs/consul-server.nix b/tv/2configs/consul-server.nix
new file mode 100644
index 0000000..d10f9ea
--- /dev/null
+++ b/tv/2configs/consul-server.nix
@@ -0,0 +1,21 @@
+{ config, ... }:
+
+{
+ tv.consul = rec {
+ enable = true;
+
+ self = config.krebs.build.host;
+ inherit (self) dc;
+
+ server = true;
+
+ hosts = with config.krebs.hosts; [
+ # TODO get this list automatically from each host where tv.consul.enable is true
+ cd
+ mkdir
+ nomic
+ rmdir
+ #wu
+ ];
+ };
+}