summaryrefslogtreecommitdiffstats
path: root/systems/ru/config.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2023-09-11 18:24:28 +0200
committertv <tv@krebsco.de>2023-09-13 18:07:11 +0200
commit0c4f3acb281be6290c55a6e96bc29fab5b5c7a11 (patch)
treedadaec00477a095273475ac345b2066b4748c399 /systems/ru/config.nix
parentab1d0479e90f11806d4703ec6fffed3d5f782914 (diff)
stockholm -> hrm
Diffstat (limited to 'systems/ru/config.nix')
-rw-r--r--systems/ru/config.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/systems/ru/config.nix b/systems/ru/config.nix
new file mode 100644
index 0000000..a79a1a7
--- /dev/null
+++ b/systems/ru/config.nix
@@ -0,0 +1,35 @@
+{ config, ... }: {
+ imports = [
+ ../../configs/hw/winmax2.nix
+ ../../configs/retiolum.nix
+ ../../configs/wiregrill.nix
+ ];
+
+ boot.initrd.luks.devices.main.device = "/dev/nvme0n1p2";
+ boot.loader.efi.canTouchEfiVariables = true;
+ boot.loader.systemd-boot.enable = true;
+
+ fileSystems."/" = {
+ device = "/dev/mapper/ruvg0-root";
+ fsType = "btrfs";
+ options = ["defaults" "noatime" "compress=zstd"];
+ };
+ fileSystems."/boot" = {
+ device = "/dev/nvme0n1p1";
+ fsType = "vfat";
+ };
+ fileSystems."/home" = {
+ device = "/dev/mapper/ruvg0-home";
+ fsType = "btrfs";
+ options = ["defaults" "noatime" "compress=zstd"];
+ };
+ fileSystems."/bku" = {
+ device = "/dev/mapper/ruvg0-bku";
+ fsType = "btrfs";
+ options = ["defaults" "noatime" "compress=zstd"];
+ };
+
+ krebs.build.host = config.krebs.hosts.ru;
+
+ system.stateVersion = "22.11";
+}