summaryrefslogtreecommitdiffstats
path: root/systems/bu/config.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2023-09-11 18:24:28 +0200
committertv <tv@krebsco.de>2023-09-13 18:07:11 +0200
commit0c4f3acb281be6290c55a6e96bc29fab5b5c7a11 (patch)
treedadaec00477a095273475ac345b2066b4748c399 /systems/bu/config.nix
parentab1d0479e90f11806d4703ec6fffed3d5f782914 (diff)
stockholm -> hrm
Diffstat (limited to 'systems/bu/config.nix')
-rw-r--r--systems/bu/config.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/systems/bu/config.nix b/systems/bu/config.nix
new file mode 100644
index 0000000..39d1007
--- /dev/null
+++ b/systems/bu/config.nix
@@ -0,0 +1,33 @@
+{ config, ... }: {
+ imports = [
+ ./disks.nix
+ ../../configs/hw/x220.nix
+ ../../configs/exim-retiolum.nix
+ ../../configs/gitconfig.nix
+ ../../configs/pulse.nix
+ ../../configs/retiolum.nix
+ ../../configs/xsessions
+ ];
+
+ krebs.build.host = config.krebs.hosts.bu;
+
+ networking.wireless.enable = true;
+ networking.useDHCP = false;
+ networking.interfaces.enp0s25.useDHCP = true;
+ networking.interfaces.wlp3s0.useDHCP = true;
+ networking.interfaces.wwp0s29u1u4i6.useDHCP = true;
+ networking.wireless.interfaces = [
+ "wlp3s0"
+ ];
+
+ programs.gnupg.agent.enable = true;
+ programs.gnupg.agent.pinentryFlavor = "gtk2";
+
+ services.earlyoom.enable = true;
+ services.earlyoom.freeMemThreshold = 5;
+ systemd.services.earlyoom.environment.EARLYOOM_ARGS = toString [
+ "--prefer '(^|/)chromium$'"
+ ];
+
+ system.stateVersion = "21.11";
+}