summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-12-06 00:02:17 +0100
committertv <tv@krebsco.de>2017-12-06 00:02:17 +0100
commitd99a1e026417bf57a4fdd38530a7fd8ba61ade9c (patch)
tree0018470b8e12024066e5cab55b3ca871e9977fb5 /shell.nix
parent3600a1bcee3cb97dfe0df1b19d171ed4ea41fc94 (diff)
stockholm: drop OLD_PATH
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 6c6b7ca..bfdf1b3 100644
--- a/shell.nix
+++ b/shell.nix
@@ -5,14 +5,13 @@ let
in pkgs.stdenv.mkDerivation {
name = "stockholm";
shellHook = /* sh */ ''
- export OLD_PATH="$PATH"
export NIX_PATH=stockholm=${toString ./.}:nixpkgs=${toString <nixpkgs>}
if test -e /nix/var/nix/daemon-socket/socket; then
export NIX_REMOTE=daemon
fi
export PATH=${lib.makeBinPath [
pkgs.stockholm
- ]}
+ ]}''${PATH+:$PATH}
eval "$(declare -F | ${pkgs.gnused}/bin/sed s/declare/unset/)"
shopt -u no_empty_cmd_completion