summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-06-30 09:44:28 +0200
committertv <tv@krebsco.de>2017-06-30 09:44:28 +0200
commitd0e8ea1a9e7f68e1a82e3ce9fb4577b7fb62f0bf (patch)
tree3a6ca4ff2f9c4f40a4b554c383fa3629a0601535 /shell.nix
parente9cc4f49e161e72c18c6e4da45b2bb95a5a2a010 (diff)
shell: use writeOut to create cmdspkg
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/shell.nix b/shell.nix
index 782b4fa..dbc2b14 100644
--- a/shell.nix
+++ b/shell.nix
@@ -151,12 +151,9 @@
echo "$date.$version"
'';
- shell.cmdspkg = pkgs.runCommand "shell.cmdspkg" {} /* sh */ ''
- mkdir -p $out/bin
- ${lib.concatStrings (lib.mapAttrsToList (name: path: /* sh */ ''
- ln -s ${path} $out/bin/${name}
- '') cmds)}
- '';
+ shell.cmdspkg = pkgs.writeOut "shell.cmdspkg" (lib.mapAttrs' (name: link:
+ lib.nameValuePair "/bin/${name}" { inherit link; }
+ ) cmds);
in pkgs.stdenv.mkDerivation {
name = "stockholm";