summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-06-30 11:04:58 +0200
committertv <tv@krebsco.de>2017-06-30 11:09:19 +0200
commit5d06c6f3f0e1122fca5d680022ea5cba15003a45 (patch)
tree1e94b602b750eaf28d16cf2fab79dbfd5f903c9c /shell.nix
parent805dd42490334acdefde06c47c96cd4082be36e0 (diff)
shell: use stockholm lib
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/shell.nix b/shell.nix
index 541a7d6..3e7ba81 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,6 @@
-{ nixpkgs ? import <nixpkgs> { overlays = [(import ./krebs/5pkgs)]; } }: let
-
- inherit (nixpkgs) lib pkgs;
- slib = import ./lib;
+let
+ lib = import ./lib;
+ pkgs = import <nixpkgs> { overlays = [(import ./krebs/5pkgs)]; };
# usage: deploy --system=SYSTEM [--target=TARGET]
cmds.deploy = pkgs.writeDash "cmds.deploy" ''