summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-07-23 00:28:35 +0200
committertv <tv@krebsco.de>2017-07-23 01:35:58 +0200
commit35ecd8bb2fb97c2150639bd1df54b532de34ef0b (patch)
tree4997750d0ea4b657547746941ca0099eac03b3e5 /shell.nix
parent8ef3a064ddde1e1caf9879302e57db809543aa55 (diff)
shell: add support for --pure
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 0a8d8dd..deca2ca 100644
--- a/shell.nix
+++ b/shell.nix
@@ -174,7 +174,8 @@ let
in pkgs.stdenv.mkDerivation {
name = "stockholm";
shellHook = /* sh */ ''
- export NIX_PATH="stockholm=$PWD''${NIX_PATH+:$NIX_PATH}"
+ export NIX_PATH=stockholm=$PWD:nixpkgs=${toString <nixpkgs>}
+ export NIX_REMOTE=daemon
export PATH=${lib.makeBinPath [
shell.cmdspkg
]}