summaryrefslogtreecommitdiffstats
path: root/shared/2configs/shack/nix-cacher.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-06-01 09:21:20 +0200
committermakefu <github@syntax-fehler.de>2017-06-01 09:22:03 +0200
commita19e4c630d187de61ccc12832ebf5e251204c315 (patch)
tree58aac4f3fd6492e4453939e4950874e252b56399 /shared/2configs/shack/nix-cacher.nix
parent5bef07d2c0ba2e765760807ddcf1e56f9d20da44 (diff)
shared: move shack config to shack/
Diffstat (limited to 'shared/2configs/shack/nix-cacher.nix')
-rw-r--r--shared/2configs/shack/nix-cacher.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/shared/2configs/shack/nix-cacher.nix b/shared/2configs/shack/nix-cacher.nix
new file mode 100644
index 0000000..4fcbf3a
--- /dev/null
+++ b/shared/2configs/shack/nix-cacher.nix
@@ -0,0 +1,28 @@
+{ config, pkgs, ... }:
+with import <stockholm/lib>;
+let
+ cfg = config.krebs.apt-cacher-ng;
+in
+{
+ krebs.apt-cacher-ng = {
+ enable = true;
+ port = 3142;
+ bindAddress = "localhost";
+ cacheExpiration = 30;
+ };
+
+ services.nginx = {
+ enable = mkDefault true;
+ virtualHosts.shack-nix-cacher = {
+ serverAliases = [
+ "acng.shack"
+ ];
+ locations."/".extraConfig = ''
+ proxy_set_header Host $host;
+ proxy_set_header X-Real-IP $remote_addr;
+ proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
+ proxy_pass http://localhost:${toString cfg.port}/;
+ '';
+ };
+ };
+}