summaryrefslogtreecommitdiffstats
path: root/shared/1systems/test-centos7.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-11-13 13:05:19 +0100
committerlassulus <lass@aidsballs.de>2015-11-13 13:05:19 +0100
commit5847c15bfaac52e1da5239ba54e8a40738865dfe (patch)
tree9a5d7ff60e8c091bcdf1cc045d605cd2c6f2ce49 /shared/1systems/test-centos7.nix
parentc501f48d06d765a52037d2966b95c19aff20d83b (diff)
move testhosts to shared from lass
Diffstat (limited to 'shared/1systems/test-centos7.nix')
-rw-r--r--shared/1systems/test-centos7.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/shared/1systems/test-centos7.nix b/shared/1systems/test-centos7.nix
new file mode 100644
index 0000000..51e9960
--- /dev/null
+++ b/shared/1systems/test-centos7.nix
@@ -0,0 +1,31 @@
+{ config, lib, pkgs, ... }:
+
+let
+ inherit (lib) head;
+
+ ip = "168.235.145.85";
+ gw = "168.235.145.1";
+in {
+ imports = [
+ ../2configs/base.nix
+ ../2configs/os-templates/CAC-CentOS-7-64bit.nix
+ {
+ networking.interfaces.enp2s1.ip4 = [
+ {
+ address = ip;
+ prefixLength = 24;
+ }
+ ];
+ networking.defaultGateway = gw;
+ networking.nameservers = [
+ "8.8.8.8"
+ ];
+
+ }
+ {
+ sound.enable = false;
+ }
+ ];
+
+ krebs.build.host = config.krebs.hosts.test-centos7;
+}