summaryrefslogtreecommitdiffstats
path: root/shared/1systems/test-centos6.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-12-20 19:37:46 +0100
committertv <tv@krebsco.de>2015-12-20 19:37:46 +0100
commita14be9e3aed1d6123f6fb99c7ca017ac2842c80d (patch)
tree3080dd1517e5179fe2feaa9e0103b5680695e18a /shared/1systems/test-centos6.nix
parent1346e53598ec77ed43f214752b0ce4be0b189646 (diff)
parent0971df6a745fd358ac9e4904d44ad48fbf0e8b6d (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'shared/1systems/test-centos6.nix')
-rw-r--r--shared/1systems/test-centos6.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/shared/1systems/test-centos6.nix b/shared/1systems/test-centos6.nix
new file mode 100644
index 0000000..a8b5f9b
--- /dev/null
+++ b/shared/1systems/test-centos6.nix
@@ -0,0 +1,30 @@
+{ config, lib, pkgs, ... }:
+
+let
+ inherit (lib) head;
+
+ ip = "168.235.148.52";
+ gw = "168.235.148.1";
+in {
+ imports = [
+ ../2configs/base.nix
+ ../2configs/os-templates/CAC-CentOS-6.5-64bit.nix
+ {
+ networking.interfaces.enp11s0.ip4 = [
+ {
+ address = ip;
+ prefixLength = 24;
+ }
+ ];
+ networking.defaultGateway = gw;
+ networking.nameservers = [
+ "8.8.8.8"
+ ];
+ }
+ {
+ sound.enable = false;
+ }
+ ];
+
+ krebs.build.host = config.krebs.hosts.test-centos6;
+}