summaryrefslogtreecommitdiffstats
path: root/old/modules/tv/iptables/options.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-07-11 19:44:12 +0200
committertv <tv@krebsco.de>2015-07-11 19:44:12 +0200
commit153422f74b1ed5cae37c9424514a9e9d1f79acb4 (patch)
tree94cd29e6a98f1ce6228104055d0550e318242290 /old/modules/tv/iptables/options.nix
parente21f45386d7aeb3dd3e9d828e1702115f4ef2bce (diff)
move old stuff
Diffstat (limited to 'old/modules/tv/iptables/options.nix')
-rw-r--r--old/modules/tv/iptables/options.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/old/modules/tv/iptables/options.nix b/old/modules/tv/iptables/options.nix
new file mode 100644
index 0000000..1adffeb
--- /dev/null
+++ b/old/modules/tv/iptables/options.nix
@@ -0,0 +1,29 @@
+{ lib, ... }:
+
+let
+ inherit (lib) mkOption types;
+in
+
+{
+ enable = mkOption {
+ type = types.bool;
+ default = false;
+ description = "Enable iptables.";
+ };
+
+ input-internet-accept-new-tcp = mkOption {
+ type = with types; listOf str;
+ default = [];
+ description = ''
+ TCP ports, accepting incoming connections from anywhere.
+ '';
+ };
+
+ input-retiolum-accept-new-tcp = mkOption {
+ type = with types; listOf str;
+ default = [];
+ description = ''
+ TCP ports, accepting incoming connections from Retiolum.
+ '';
+ };
+}