summaryrefslogtreecommitdiffstats
path: root/old/modules/tv/iptables/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-07-11 19:44:12 +0200
committertv <tv@krebsco.de>2015-07-11 19:44:12 +0200
commit153422f74b1ed5cae37c9424514a9e9d1f79acb4 (patch)
tree94cd29e6a98f1ce6228104055d0550e318242290 /old/modules/tv/iptables/default.nix
parente21f45386d7aeb3dd3e9d828e1702115f4ef2bce (diff)
move old stuff
Diffstat (limited to 'old/modules/tv/iptables/default.nix')
-rw-r--r--old/modules/tv/iptables/default.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/old/modules/tv/iptables/default.nix b/old/modules/tv/iptables/default.nix
new file mode 100644
index 0000000..cf27a26
--- /dev/null
+++ b/old/modules/tv/iptables/default.nix
@@ -0,0 +1,11 @@
+arg@{ config, lib, pkgs, ... }:
+
+let
+ cfg = config.tv.iptables;
+ arg' = arg // { inherit cfg; };
+in
+
+{
+ options.tv.iptables = import ./options.nix arg';
+ config = lib.mkIf cfg.enable (import ./config.nix arg');
+}