summaryrefslogtreecommitdiffstats
path: root/old/modules/common/sshkeys.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-07-11 19:44:12 +0200
committertv <tv@krebsco.de>2015-07-11 19:44:12 +0200
commit153422f74b1ed5cae37c9424514a9e9d1f79acb4 (patch)
tree94cd29e6a98f1ce6228104055d0550e318242290 /old/modules/common/sshkeys.nix
parente21f45386d7aeb3dd3e9d828e1702115f4ef2bce (diff)
move old stuff
Diffstat (limited to 'old/modules/common/sshkeys.nix')
-rw-r--r--old/modules/common/sshkeys.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/old/modules/common/sshkeys.nix b/old/modules/common/sshkeys.nix
new file mode 100644
index 0000000..5f1c606
--- /dev/null
+++ b/old/modules/common/sshkeys.nix
@@ -0,0 +1,26 @@
+{ lib, ... }:
+
+with lib;
+
+{
+ options = {
+ sshKeys = mkOption {
+ type = types.attrsOf (types.submodule (
+ { config, ... }:
+ {
+ options = {
+ pub = mkOption {
+ type = types.str;
+ description = "Public part of the ssh key.";
+ };
+
+ priv = mkOption {
+ type = types.str;
+ description = "Private part of the ssh key.";
+ };
+ };
+ }));
+ description = "collection of ssh-keys";
+ };
+ };
+}