summaryrefslogtreecommitdiffstats
path: root/modules/wu/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-06-22 20:11:02 +0200
committertv <tv@krebsco.de>2015-06-22 20:11:02 +0200
commit1daced7dae93c694ea4b26d398c147f45ad65856 (patch)
tree385aed841a2d9f7320ca35a3ce67093cb5b8470e /modules/wu/default.nix
parent0df90750a9576d0b2da0894162c35a305403251a (diff)
tv retiolum: split module into options and config
Diffstat (limited to 'modules/wu/default.nix')
-rw-r--r--modules/wu/default.nix31
1 files changed, 11 insertions, 20 deletions
diff --git a/modules/wu/default.nix b/modules/wu/default.nix
index f723146..54b8587 100644
--- a/modules/wu/default.nix
+++ b/modules/wu/default.nix
@@ -14,7 +14,6 @@ in
../common/nixpkgs.nix
../tv/base.nix
../tv/exim-retiolum.nix
- ../tv/retiolum.nix
../tv/sanitize.nix
../tv/smartd.nix
../tv/synaptics.nix
@@ -44,6 +43,17 @@ in
];
};
}
+ {
+ imports = [ ../tv/retiolum ];
+ tv.retiolum = {
+ enable = true;
+ hosts = <retiolum-hosts>;
+ connectTo = [
+ "gum"
+ "pigstarter"
+ ];
+ };
+ }
];
nix.maxJobs = 8;
@@ -342,25 +352,6 @@ in
# '';
#};
- services.retiolum = {
- enable = true;
- hosts = <retiolum-hosts>;
- connectTo = [
- "gum"
- "pigstarter"
- ];
- };
-
- # TODO
- #services.tinc = {
- # enable = true;
- # network = "retiolum";
- # hosts = /home/tv/krebs/hosts;
- # privateKeyFile = /etc/tinc/retiolum/rsa_key.priv;
- # connectTo = [ "fastpoke" "pigstarter" "kheurop" ];
- #};
-
-
security.rtkit.enable = false;
services.nscd.enable = false;
services.ntp.enable = false;