summaryrefslogtreecommitdiffstats
path: root/modules/tv/nginx/options.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-06-22 18:20:25 +0200
committertv <tv@krebsco.de>2015-06-22 18:20:25 +0200
commit245c7842072c8dec51ab6aca07437b826c38b242 (patch)
tree1056515620276960498f3c7455624802d6173620 /modules/tv/nginx/options.nix
parent14f619e3efbea9d614aa46f3d0d04b8d7d0c8e33 (diff)
tv: modularize nginx
Diffstat (limited to 'modules/tv/nginx/options.nix')
-rw-r--r--modules/tv/nginx/options.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/tv/nginx/options.nix b/modules/tv/nginx/options.nix
new file mode 100644
index 0000000..ddfb380
--- /dev/null
+++ b/modules/tv/nginx/options.nix
@@ -0,0 +1,21 @@
+{ lib, ... }:
+
+let
+ inherit (lib) mkOption types;
+in
+
+{
+ enable = mkOption {
+ type = types.bool;
+ default = false;
+ description = "Enable nginx.";
+ };
+
+ retiolum-locations = mkOption {
+ type = with types; listOf (attrsOf str);
+ default = [];
+ description = ''
+ TODO
+ '';
+ };
+}