summaryrefslogtreecommitdiffstats
path: root/modules/tv/base.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-04-08 01:07:01 +0200
committertv <tv@krebsco.de>2015-05-19 23:16:56 +0200
commit305994b23565b3e0f73922ca219cbcb9872e4daa (patch)
tree14dd49072264f70f32d826fadc3489a7b101b62c /modules/tv/base.nix
parentee0c09d16f1e857a9f37118babc5c2a061fa9cf1 (diff)
I Like To Move It
Diffstat (limited to 'modules/tv/base.nix')
-rw-r--r--modules/tv/base.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/modules/tv/base.nix b/modules/tv/base.nix
new file mode 100644
index 0000000..76c8b89
--- /dev/null
+++ b/modules/tv/base.nix
@@ -0,0 +1,17 @@
+{ config, pkgs, ... }:
+
+{
+ time.timeZone = "Europe/Berlin";
+
+ nix.maxJobs = 8;
+ nix.useChroot = true;
+ # TODO check if both are required:
+ nix.chrootDirs = [ "/etc/protocols" pkgs.iana_etc.outPath ];
+
+ nix.trustedBinaryCaches = [
+ "https://cache.nixos.org"
+ "http://cache.nixos.org"
+ "http://hydra.nixos.org"
+ ];
+
+}