summaryrefslogtreecommitdiffstats
path: root/modules/mors/repos.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-05-25 19:32:54 +0200
committerlassulus <lass@aidsballs.de>2015-05-25 19:32:54 +0200
commit4c7abddb0ea4b3c6812f0d3f37262b9c74648f5e (patch)
tree5c29a048415e5612834dad2bce02f3323d41f9ad /modules/mors/repos.nix
parent3c460ef77a2d05848eecb4382b0c6f368785e776 (diff)
activate gitolite config
Diffstat (limited to 'modules/mors/repos.nix')
-rw-r--r--modules/mors/repos.nix75
1 files changed, 75 insertions, 0 deletions
diff --git a/modules/mors/repos.nix b/modules/mors/repos.nix
new file mode 100644
index 0000000..6d3cf21
--- /dev/null
+++ b/modules/mors/repos.nix
@@ -0,0 +1,75 @@
+{ ... }:
+
+{
+ imports = [
+ ../lass/gitolite-base.nix
+ ];
+
+ services.gitolite = {
+ repos = {
+
+ config = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ tv = "R";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ pass = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ };
+ };
+
+ load-env = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ tv = "R";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ emse-hsdb = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ tv = "R";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ painload = {
+ users = {
+ lass = "RW+";
+ tv = "R";
+ makefu = "R";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ brain = {
+ users = {
+ lass = "RW+";
+ tv = "R";
+ makefu = "R";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ services = {
+ users = {
+ lass = "RW+";
+ tv = "R";
+ makefu = "R";
+ reaktor = "R";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ };
+ };
+}