summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2018-12-02 14:14:03 +0100
committertv <tv@krebsco.de>2018-12-02 14:14:03 +0100
commita69837925da39988eb9ddeb5e00664ed5eda3d3f (patch)
tree1c4b4b2160cb8854181278a62b8c7d6addfcb7be /lib/types.nix
parenta2d0d1d6260a7e52ee1d7ccc083da56a0eafb748 (diff)
lib.types.user: use genid_uint31
Refs https://github.com/systemd/systemd/issues/11026
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/types.nix b/lib/types.nix
index d663d25..0168533 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -3,7 +3,7 @@
let
inherit (lib)
all any attrNames concatMapStringsSep concatStringsSep const filter flip
- genid hasSuffix head isInt isString length mergeOneOption mkOption
+ genid_uint31 hasSuffix head isInt isString length mergeOneOption mkOption
mkOptionType optional optionalAttrs optionals range splitString
stringLength substring test testString typeOf;
inherit (lib.types)
@@ -365,7 +365,7 @@ rec {
};
uid = mkOption {
type = int;
- default = genid config.name;
+ default = genid_uint31 config.name;
};
};
});
@@ -377,7 +377,7 @@ rec {
};
gid = mkOption {
type = int;
- default = genid config.name;
+ default = genid_uint31 config.name;
};
};
});