summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2020-10-18 19:25:11 +0200
committerlassulus <lassulus@lassul.us>2020-10-18 19:25:11 +0200
commit9ac104267009988ae2ae5c254984e256bd9a6957 (patch)
tree594aa3e871a5d465bf62a4604128ea27fd2a0ed2 /lib/types.nix
parent258365a1bad616440f08d6b505779a5dfb04f160 (diff)
parentc5222bc188414a753fe8e8260c6dac26f05ac2e9 (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 3eda226..689a2c8 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -116,6 +116,10 @@ rec {
type = listOf hostname;
default = [];
};
+ mac = mkOption {
+ type = nullOr str;
+ default = null;
+ };
ip4 = mkOption {
type = nullOr (submodule {
options = {