summaryrefslogtreecommitdiffstats
path: root/jeschli/1systems/bln/hardware-configuration.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-12-15 13:33:48 +0100
committerlassulus <lassulus@lassul.us>2017-12-15 13:35:07 +0100
commitb60fa758339c6e41bd6aace627def7a8f6b30b4f (patch)
tree8e64efa16658cf71c1074ade1856c31dc052871a /jeschli/1systems/bln/hardware-configuration.nix
parent7ca64ead1136ca7c906e4aa5b88e13ca9bcd32b0 (diff)
jeschli: add bln
Diffstat (limited to 'jeschli/1systems/bln/hardware-configuration.nix')
-rw-r--r--jeschli/1systems/bln/hardware-configuration.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/jeschli/1systems/bln/hardware-configuration.nix b/jeschli/1systems/bln/hardware-configuration.nix
new file mode 100644
index 0000000..7141622
--- /dev/null
+++ b/jeschli/1systems/bln/hardware-configuration.nix
@@ -0,0 +1,34 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+ imports =
+ [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "usbhid" "sd_mod" "rtsx_pci_sdmmc" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/02144ea4-947d-440e-bbf9-99cab0dccf05";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/f169fd32-bf96-4da0-bc34-294249ffa606";
+ fsType = "ext2";
+ };
+
+ fileSystems."/home" =
+ { device = "/dev/disk/by-uuid/68ef2163-7b3d-4dbb-add9-d3543ad7c738";
+ fsType = "ext4";
+ };
+
+ swapDevices = [ ];
+
+ nix.maxJobs = lib.mkDefault 4;
+ powerManagement.cpuFreqGovernor = "powersave";
+}