summaryrefslogtreecommitdiffstats
path: root/4lib/krebs/dns.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-07-28 15:29:59 +0200
committerlassulus <lass@aidsballs.de>2015-07-28 15:29:59 +0200
commit7acd1262519d8f15c8eb89a0dce968eb26d6b7d4 (patch)
tree71f807a36e60e126b6fdb0be51e70cde4bf64b4e /4lib/krebs/dns.nix
parent7673c84204bd5bae0426b79c62e95dfccf846756 (diff)
parent7920cfad18e69ea30bbe5e70da2cd93e0bbc05cd (diff)
Merge branch 'tv' into master
Diffstat (limited to '4lib/krebs/dns.nix')
-rw-r--r--4lib/krebs/dns.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/4lib/krebs/dns.nix b/4lib/krebs/dns.nix
new file mode 100644
index 0000000..b2cf3c2
--- /dev/null
+++ b/4lib/krebs/dns.nix
@@ -0,0 +1,31 @@
+{ lib, ... }:
+
+let
+ listset = import ./listset.nix { inherit lib; };
+in
+
+with builtins;
+with lib;
+
+rec {
+ # label = string
+
+ # TODO does it make sense to have alias = list label?
+
+ # split-by-provider :
+ # [[label]] -> tree label provider -> listset provider alias
+ split-by-provider = as: providers:
+ foldl (m: a: listset.insert (provider-of a providers) a m) {} as;
+
+ # provider-of : alias -> tree label provider -> provider
+ # Note that we cannot use tree.get here, because path can be longer
+ # than the tree depth.
+ provider-of = a:
+ let
+ go = path: tree:
+ if typeOf tree == "string"
+ then tree
+ else go (tail path) tree.${head path};
+ in
+ go (reverseList (splitString "." a));
+}