summaryrefslogtreecommitdiffstats
path: root/3modules/tv/identity.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-07-13 17:36:31 +0200
committertv <tv@krebsco.de>2015-07-13 17:47:49 +0200
commit5eb2a9be177c685643e63ac5da19dff78e733e46 (patch)
tree73cd25f1107480295823ca5f904362f98401e85a /3modules/tv/identity.nix
parenta3f12c30d15b3b38b05d757fb91d84865ce2a7ef (diff)
3 tv.*: use mkEnableOption
Diffstat (limited to '3modules/tv/identity.nix')
-rw-r--r--3modules/tv/identity.nix8
1 files changed, 2 insertions, 6 deletions
diff --git a/3modules/tv/identity.nix b/3modules/tv/identity.nix
index 7cf90de..c3c2f17 100644
--- a/3modules/tv/identity.nix
+++ b/3modules/tv/identity.nix
@@ -1,9 +1,7 @@
{ lib, ... }:
with lib;
-
let
-
cfg = config.tv.identity;
out = {
@@ -12,10 +10,8 @@ let
};
api = {
- enable = mkOption {
- type = types.bool;
- default = false;
- };
+ enable = mkEnableOption "tv.identity";
+
self = mkOption {
type = types.unspecified;
};