summaryrefslogtreecommitdiffstats
path: root/3modules/makefu/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-07-24 22:39:11 +0200
committermakefu <github@syntax-fehler.de>2015-07-24 22:39:11 +0200
commit8fff2bebdb150d096095f57fa12a1c1f6a6a5547 (patch)
tree6cc7c5b1c968dea7ae58ad58a20c0978bfc6c56b /3modules/makefu/default.nix
parenta4d676e4c5cd2c5cfcd9388074ba74c7714f754a (diff)
pnp provides cgit, update identity
Diffstat (limited to '3modules/makefu/default.nix')
-rw-r--r--3modules/makefu/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/3modules/makefu/default.nix b/3modules/makefu/default.nix
new file mode 100644
index 0000000..45ca8c3
--- /dev/null
+++ b/3modules/makefu/default.nix
@@ -0,0 +1,19 @@
+{ config, lib, ... }:
+
+with import ../../4lib/krebs { inherit lib; };
+let
+ cfg = config.krebs;
+
+ out = {
+ imports = [
+ ];
+ options.krebs = api;
+ config = mkIf cfg.enable imp;
+ };
+
+ api = { };
+
+ imp = { };
+
+in
+out