summaryrefslogtreecommitdiffstats
path: root/3modules/krebs/git.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-07-24 21:04:22 +0200
committermakefu <github@syntax-fehler.de>2015-07-24 21:04:22 +0200
commit6b2a9d6b26ef75ee78c96839d4aa06ab027fcf4e (patch)
treeedae5b9996be874d0795571af2f1356e4b904a2b /3modules/krebs/git.nix
parent8cf043ca2014e566ce2dc056d392fe9f85dc7cb7 (diff)
parent2154167857b6bd35c8b1cce2ad41521164abb2ff (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to '3modules/krebs/git.nix')
-rw-r--r--3modules/krebs/git.nix11
1 files changed, 4 insertions, 7 deletions
diff --git a/3modules/krebs/git.nix b/3modules/krebs/git.nix
index 2d747cc..499d330 100644
--- a/3modules/krebs/git.nix
+++ b/3modules/krebs/git.nix
@@ -6,8 +6,7 @@
# TODO when authorized_keys changes, then restart ssh
# (or kill already connected users somehow)
-with builtins;
-with lib;
+with import ../../4lib/krebs { inherit lib; };
let
cfg = config.krebs.git;
@@ -127,9 +126,6 @@ let
rules = mkOption {
type = types.unspecified;
};
- users = mkOption {
- type = types.unspecified;
- };
};
git-imp = {
@@ -157,7 +153,8 @@ let
name = "git";
shell = "/bin/sh";
openssh.authorizedKeys.keys =
- mapAttrsToList (_: makeAuthorizedKey git-ssh-command) cfg.users;
+ mapAttrsToList (_: makeAuthorizedKey git-ssh-command)
+ config.krebs.users;
uid = 129318403; # genid git
};
};
@@ -263,7 +260,7 @@ let
isPublicRepo = getAttr "public"; # TODO this is also in ./cgit.nix
- makeAuthorizedKey = git-ssh-command: user@{ name, pubkey }:
+ makeAuthorizedKey = git-ssh-command: user@{ name, pubkey, ... }:
# TODO assert name
# TODO assert pubkey
let