aboutsummaryrefslogtreecommitdiffstats
path: root/disko.nix
diff options
context:
space:
mode:
Diffstat (limited to 'disko.nix')
-rw-r--r--disko.nix48
1 files changed, 0 insertions, 48 deletions
diff --git a/disko.nix b/disko.nix
deleted file mode 100644
index e345cdc..0000000
--- a/disko.nix
+++ /dev/null
@@ -1,48 +0,0 @@
-# usage: nix-instantiate --eval --json disko.nix | jq -r .
-with import <nixpkgs/lib>;
-with builtins;
-
-let
-
- fun.filesystem = q: x: ''
- mkfs.${x.format} ${q.device}
- '';
-
- fun.lvm = q: x: ''
- pvcreate ${q.device}
- vgcreate ${x.name} ${q.device}
- ${concatStringsSep "\n" (mapAttrsToList (name: f (q // { inherit name; vgname = x.name; device = null; /* ??? */ })) x.lvs)}
- '';
-
- fun.luks = q: x: ''
- cryptsetup -q luksFormat ${q.device} ${x.keyfile}
- cryptsetup luksOpen ${q.device} ${x.name} --key-file ${x.keyfile}
-
- ${f (q // { device = "/dev/mapper/${x.name}"; }) x.content}
- '';
-
- fun.partition = q: x:
- throw "this should not happen, partitions are managed in fun.table";
-
- fun.table = q: x: ''
- parted -s -a optimal ${q.device} mklabel ${x.format}
- ${concatStringsSep "\n" (imap (i: part: "parted -s -a optimal ${q.device} mkpart ${part.part-type} ${part.fs-type or ""} ${part.start} ${part.end} ${optionalString (part.bootable or false) "\nparted -s -a optimal ${q.device} set ${toString i} boot on "}") x.partitions)}
-
- ${concatStrings (imap (i: x: f (q // { device = q.device + toString i; }) x.content) x.partitions)}
- '';
-
- fun.lv = q: x: ''
- lvcreate -L ${x.size} -n ${q.name} ${q.vgname}
-
- ${f (q // { device = "/dev/${q.vgname}/${q.name}"; }) x.content}
- '';
-
- f = q: x: fun.${x.type} q x;
-
- q0.device = "/dev/sda";
- x0 = import ./example.nix;
-
-in ''
- set -efu
- ${f q0 x0}
-''