summaryrefslogtreecommitdiffstats
path: root/cgserver.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-02-24 21:54:52 +0100
committertv <tv@shackspace.de>2015-02-24 22:06:00 +0100
commitadbb6de170e6a3215b461798e5cfdd823bd01e45 (patch)
tree1419fd45bd7f704b2131e6e65d8809364ca2697e /cgserver.nix
parent75e3d1e803826cd433b41fb3ecde8eb892f42bf7 (diff)
Diffstat (limited to 'cgserver.nix')
-rw-r--r--cgserver.nix21
1 files changed, 8 insertions, 13 deletions
diff --git a/cgserver.nix b/cgserver.nix
index bd8d12b..28c4b16 100644
--- a/cgserver.nix
+++ b/cgserver.nix
@@ -1,21 +1,16 @@
-# This file was auto-generated by cabal2nix. Please do NOT edit manually!
-
-{ cabal, aeson, attoparsec, filepath, httpTypes, ioStreams, safe
-, text, wai, waiExtra, warp
+{ mkDerivation, aeson, attoparsec, base, bytestring, containers
+, directory, filepath, http-types, io-streams, safe, stdenv, text
+, wai, wai-extra, warp
}:
-
-cabal.mkDerivation (self: {
+mkDerivation {
pname = "cgserver";
version = "0.1.0.0";
src = ./.;
isLibrary = false;
isExecutable = true;
buildDepends = [
- aeson attoparsec filepath httpTypes ioStreams safe text wai
- waiExtra warp
+ aeson attoparsec base bytestring containers directory filepath
+ http-types io-streams safe text wai wai-extra warp
];
- meta = {
- license = self.stdenv.lib.licenses.bsd3;
- platforms = self.ghc.meta.platforms;
- };
-})
+ license = stdenv.lib.licenses.bsd3;
+}