aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 9 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 959d4c7..7b78171 100644
--- a/setup.py
+++ b/setup.py
@@ -3,17 +3,21 @@ from setuptools import setup
setup(
name='Reaktor',
- version='0.2.3',
+ version='0.3.2',
description='an IRC bot based on asyn* libs',
long_description=open("README.md").read(),
license='WTFPL',
- url='http://localhost/',
- download_url='http://localhost/',
+ url='http://krebsco.de/',
+ download_url='https://pypi.python.org/pypi/Reaktor/',
author='krebs',
author_email='spam@krebsco.de',
install_requires = [ 'docopt' ],
+ extras_require = {
+ # 'all-plugins' : ['dnsrecon'] < not yet in pypi
+ },
+
packages=['reaktor'],
# optional non-python Deps:
# whatweb in path for 'whatweb'
@@ -21,6 +25,7 @@ setup(
# host for 'taken'
# whois for 'whois'
# git for 'nag'
+ package_data = {'reaktor' : ['commands/*'] },
entry_points={
'console_scripts' : [
'reaktor = reaktor.core:main'
@@ -31,6 +36,7 @@ setup(
"Intended Audience :: Developers",
"Natural Language :: English",
"Operating System :: POSIX :: Linux",
+ "Development Status :: 3 - Alpha",
"Programming Language :: Python",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",