aboutsummaryrefslogtreecommitdiffstats
path: root/Reaktor.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-08-31 13:10:17 +0200
committermakefu <github@syntax-fehler.de>2015-08-31 13:10:17 +0200
commitbeca84306888be2a627ae2ab14530f853b1218ed (patch)
tree51371b1a426312e3ddb817d97599cc05bc319a9e /Reaktor.nix
parent7eba4293714b9dce86c07ccf2fdaddaa11a4c3c7 (diff)
Reaktor: update deps
Diffstat (limited to 'Reaktor.nix')
-rw-r--r--Reaktor.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/Reaktor.nix b/Reaktor.nix
index b804b44..0f9a2ed 100644
--- a/Reaktor.nix
+++ b/Reaktor.nix
@@ -1,15 +1,24 @@
with import <nixpkgs> {};
# nix-build Reaktor.nix
# result/bin/reaktor
+## or in your env
+# nix-env -i -f Reaktor.nix
buildPythonPackage rec {
name = "Reaktor-${version}";
version = "0.2.6";
- propagatedBuildInputs = with pkgs.pythonPackages;[
+ propagatedBuildInputs = with pkgs;[
pythonPackages.docopt
+ utillinux # for tell_on-join
+ git
];
src = fetchurl {
- url = "https://pypi.python.org/packages/source/R/Reaktor/Reaktor-0.2.6.tar.gz";
+ url = "https://pypi.python.org/packages/source/R/Reaktor/Reaktor-${version}.tar.gz";
sha256 = "1dksw1s1n2hxvnga6pygjr174dywncr0wiggkrkn1srbn2amh1c2";
};
+ meta = {
+ homepage = http://krebsco.de/;
+ description = "An IRC bot based on asynchat";
+ license = stdenv.lib.licenses.wtfpl;
+ };
}