summaryrefslogtreecommitdiffstats
path: root/modules/cd/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/cd/default.nix')
-rw-r--r--modules/cd/default.nix37
1 files changed, 22 insertions, 15 deletions
diff --git a/modules/cd/default.nix b/modules/cd/default.nix
index 1d621e03d..7223203a0 100644
--- a/modules/cd/default.nix
+++ b/modules/cd/default.nix
@@ -11,7 +11,7 @@
../tv/base-cac-CentOS-7-64bit.nix
../tv/ejabberd.nix # XXX echtes modul
../tv/exim-smarthost.nix
- ../tv/git.nix
+ ../tv/git
../tv/retiolum.nix
../tv/sanitize.nix
];
@@ -48,7 +48,7 @@
let
inherit (builtins) readFile;
# TODO lib should already include our stuff
- inherit (import ../../lib { inherit lib; }) addNames git;
+ inherit (import ../../lib { inherit lib pkgs; }) addNames git;
in
rec {
enable = true;
@@ -59,31 +59,38 @@
makefu = { pubkey = "xxx"; };
};
- # TODO warn about stale repodirs
repos = addNames {
+ shitment = {
+ desc = "shitment repository";
+ hooks = {
+ post-receive = git.irc-announce {
+ nick = config.networking.hostName; # TODO make this the default
+ channel = "#retiolum";
+ server = "ire.retiolum";
+ };
+ };
+ public = true;
+ };
testing = {
+ desc = "testing repository";
hooks = {
- update = ''
- #! /bin/sh
- set -euf
- echo update hook: $* >&2
- '';
- post-update = ''
- #! /bin/sh
- set -euf
- echo post-update hook: $* >&2
- '';
+ post-receive = git.irc-announce {
+ nick = config.networking.hostName; # TODO make this the default
+ channel = "#repository";
+ server = "ire.retiolum";
+ };
};
+ public = true;
};
};
rules = with git; with users; with repos; [
{ user = tv;
- repo = testing;
+ repo = [ testing shitment ];
perm = push master [ non-fast-forward create delete merge ];
}
{ user = [ lass makefu ];
- repo = testing;
+ repo = [ testing shitment ];
perm = fetch;
}
];