summaryrefslogtreecommitdiffstats
path: root/makefu/source.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/source.nix')
-rw-r--r--makefu/source.nix20
1 files changed, 18 insertions, 2 deletions
diff --git a/makefu/source.nix b/makefu/source.nix
index ce5855430..647803fd7 100644
--- a/makefu/source.nix
+++ b/makefu/source.nix
@@ -4,14 +4,16 @@ host@{ name,
secure ? false,
full ? false,
torrent ? false,
- musnix ? false
+ hw ? false,
+ musnix ? false,
+ python ? false
}:
let
builder = if getEnv "dummy_secrets" == "true"
then "buildbot"
else "makefu";
_file = <stockholm> + "/makefu/1systems/${name}/source.nix";
- ref = "3874de4"; # unstable @ 2017-12-08
+ ref = "3e8d708"; # nixos-17.09 @ 2018-01-05
# + do_sqlite3 ruby: 55a952be5b5
in
@@ -45,6 +47,20 @@ in
ref = "d8b989f";
};
})
+
+ (mkIf ( hw ) {
+ nixos-hardware.git = {
+ url = https://github.com/nixos/nixos-hardware.git;
+ ref = "8a05dc9";
+ };
+ })
+
+ (mkIf ( python ) {
+ python.git = {
+ url = https://github.com/garbas/nixpkgs-python;
+ ref = "cac319b";
+ };
+ })
(mkIf ( torrent ) {
torrent-secrets.file = getAttr builder {
buildbot = toString <stockholm/makefu/6tests/data/secrets>;