summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/acdcli/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/5pkgs/acdcli/default.nix')
-rw-r--r--makefu/5pkgs/acdcli/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/makefu/5pkgs/acdcli/default.nix b/makefu/5pkgs/acdcli/default.nix
new file mode 100644
index 000000000..1621375e3
--- /dev/null
+++ b/makefu/5pkgs/acdcli/default.nix
@@ -0,0 +1,20 @@
+{ lib, pkgs, python3Packages, fetchurl, ... }:
+
+with python3Packages; buildPythonPackage rec {
+ name = "acdcli-${version}";
+ version = "0.3.2";
+ propagatedBuildInputs = [
+ dateutil colorama fusepy appdirs requests2 requests_toolbelt six
+ ];
+ src = fetchurl {
+ url = "mirror://pypi/a/acdcli/${name}.tar.gz";
+ sha256 = "1ak9xxpyb7n6iyalf2082jpimklakm0fgm7vsv7qcm8wy6vlq2cw";
+ };
+ doCheck = false; # ImportError: Failed to import test module: tests
+ postFixup = ''
+ mv $out/bin/.acd_cli.py-wrapped $out/bin/acd_cli.py
+ '';
+ meta = {
+ description = "communicate with amazon drive";
+ };
+}