summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/vpn/vpnws/client.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/vpn/vpnws/client.nix')
-rw-r--r--makefu/2configs/vpn/vpnws/client.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/makefu/2configs/vpn/vpnws/client.nix b/makefu/2configs/vpn/vpnws/client.nix
new file mode 100644
index 000000000..d06bc27db
--- /dev/null
+++ b/makefu/2configs/vpn/vpnws/client.nix
@@ -0,0 +1,9 @@
+{ pkgs, ... }:
+{
+ users.users.makefu.packages = with pkgs; [ iproute vpn-ws ];
+ # vpn-ws-client vpnws wss://localhost/vpn --no-verify --exec "ip link set vpnws up;ip addr add 10.244.1.2/24 dev vpnws"
+ networking.interfaces.vpnws = {
+ virtual = true;
+ virtualType = "tap";
+ };
+}