summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/deployment/led-fader/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/deployment/led-fader/default.nix')
-rw-r--r--makefu/2configs/deployment/led-fader/default.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/makefu/2configs/deployment/led-fader/default.nix b/makefu/2configs/deployment/led-fader/default.nix
deleted file mode 100644
index fee741997..000000000
--- a/makefu/2configs/deployment/led-fader/default.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with import <stockholm/lib>;
-let
- mq = "192.168.8.11";
-in {
- systemd.services.led-fader = {
- description = "Send led change to message queue";
- environment = {
- NIX_PATH = "/var/src";
- };
- wantedBy = [ "multi-user.target" ];
- path = with pkgs; [
- nix # nix-shell
- mosquitto #mosquitto_pub
- bash # nix-shell
- ];
- serviceConfig = {
- # User = "nobody"; # need a user with permissions to run nix-shell
- ExecStart = pkgs.writeDash "run-fader" ''
- ${./fade.py} --add-empty --mode chain 3 loop --skip-unchanged 0.002 0.1 \
- | mosquitto_pub -h ${mq} -p 1883 -l -t '/leds/nodemcu-switcher/set'
- '';
- PrivateTmp = true;
- };
- };
-}