summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix15
1 files changed, 13 insertions, 2 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 8c6846887..70570a6b3 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -31,9 +31,20 @@ rec {
default = null;
};
- managed = mkOption {
+ ci = mkOption {
description = ''
- If true, then the host's configuration is defined in stockholm.
+ If true, then the host wants to be tested by some CI system.
+ See <stockholm/krebs/2configs/buildbot-all.nix>
+ '';
+ type = bool;
+ default = false;
+ };
+
+ external = mkOption {
+ description = ''
+ Whether the host is defined externally (in contrast to being defined
+ in <stockholm>). This is useful e.g. when legacy and/or adopted
+ hosts should be part of retiolum or some other component.
'';
type = bool;
default = false;