summaryrefslogtreecommitdiffstats
path: root/lass/krops.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/krops.nix')
-rw-r--r--lass/krops.nix16
1 files changed, 7 insertions, 9 deletions
diff --git a/lass/krops.nix b/lass/krops.nix
index 776a3a55d..c5a932206 100644
--- a/lass/krops.nix
+++ b/lass/krops.nix
@@ -1,4 +1,4 @@
-{ config ? config, name }: let
+{ name }: let
inherit (import ../krebs/krops.nix { inherit name; })
krebs-source
lib
@@ -10,7 +10,7 @@
{
nixos-config.symlink = "stockholm/lass/1systems/${name}/physical.nix";
secrets = if test then {
- file = "/home/lass/stockholm/lass/2configs/tests/dummy-secrets";
+ file = toString ./2configs/tests/dummy-secrets;
} else {
pass = {
dir = "${lib.getEnv "HOME"}/.password-store";
@@ -30,13 +30,11 @@ in {
# usage: $(nix-build --no-out-link --argstr name HOSTNAME -A test)
test = pkgs.krops.writeTest "${name}-test" {
source = source { test = true; };
- target = "${lib.getEnv "HOME"}/tmp/${name}-krops-test-src";
+ target = "${lib.getEnv "HOME"}/tmp/${name}-stockholm-test";
};
- ci = map (host:
- pkgs.krops.writeTest "${host.name}-test" {
- source = source { test = true; };
- target = "${lib.getEnv "TMPDIR"}/lass/${host.name}";
- }
- ) (lib.filter (host: lib.getAttr "ci" host && host.owner == "lass") (lib.attrValues config.krebs.hosts));
+ ci = pkgs.krops.writeTest "${name}-test" {
+ source = source { test = true; };
+ target = "${lib.getEnv "HOME"}/stockholm-build";
+ };
}