summaryrefslogtreecommitdiffstats
path: root/lass/2configs/xresources.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/xresources.nix')
-rw-r--r--lass/2configs/xresources.nix63
1 files changed, 0 insertions, 63 deletions
diff --git a/lass/2configs/xresources.nix b/lass/2configs/xresources.nix
deleted file mode 100644
index a3c54f3a1..000000000
--- a/lass/2configs/xresources.nix
+++ /dev/null
@@ -1,63 +0,0 @@
-{ config, pkgs, ... }:
-
-with import <stockholm/lib>;
-
-let
-
- xresources = pkgs.writeText "Xresources" ''
- URxvt*scrollBar: false
- URxvt*urgentOnBell: true
- URxvt*SaveLines: 4096
-
- URxvt.font: ${config.lass.fonts.regular}
- URxvt.boldFont: ${config.lass.fonts.bold}
- URxvt.italicFont: ${config.lass.fonts.italic}
-
- ! ref https://github.com/muennich/urxvt-perls
- URxvt.perl-lib: ${pkgs.urxvt_perls}/lib/urxvt/perl
- URxvt.perl-ext-common: default,clipboard,url-select,keyboard-select
- ${optionalString (hasAttr "browser" config.lass)
- "URxvt.url-select.launcher: ${config.lass.browser.select}/bin/browser-select"
- }
- URxvt.url-select.underline: true
- URxvt.keysym.M-u: perl:url-select:select_next
- URxvt.keysym.M-Escape: perl:keyboard-select:activate
- URxvt.keysym.M-s: perl:keyboard-select:search
-
- URxvt.intensityStyles: false
-
- URxvt*background: #000000
- URxvt*foreground: #d0d7d0
-
- URxvt*cursorColor: #f042b0
- URxvt*cursorColor2: #f0b000
- URxvt*cursorBlink: off
-
- URxvt*.pointerBlank: true
- URxvt*.pointerBlankDelay: 987654321
- URxvt*.pointerColor: #f042b0
- URxvt*.pointerColor2: #050505
-
- URxvt*color0: #232342
- '';
-
-in {
- systemd.services.xresources = {
- description = "xresources";
- wantedBy = [ "multi-user.target" ];
- after = [ "display-manager.service" ];
-
- environment = {
- DISPLAY = ":0";
- };
-
- restartIfChanged = true;
-
- serviceConfig = {
- Type = "simple";
- ExecStart = "${pkgs.xorg.xrdb}/bin/xrdb -merge ${xresources}";
- Restart = "on-failure";
- User = "lass";
- };
- };
-}